Build Zencash (ZEN) wallet on Ubuntu

Build Zencash (ZEN) wallet on Ubuntu:

Build everything:

sudo apt-get install build-essential pkg-config libc6-dev m4 g++-multilib autoconf libtool ncurses-dev unzip git python zlib1g-dev wget bsdmainutils automake

The actual build takes a long time:

mkdir ~/source
cd ~/source
git clone https://github.com/ZencashOfficial/zen.git
cd ~/source/zen/zcutil
./build.sh
./fetch-params.sh

Run wallet and then stop it:

cd ~/source/zen/src
./zend -daemon
./zen-cli stop

You will now see a folder ~/.zen
Create zen.conf in this folder that looks like this:

rpcuser=YourUserName
rpcpassword=YourPassword
rpcport=8236
gen=1

Now start the server again:

cd ~/source/zen/src
./zend -daemon

Use the cli (command line interface) to getinfo:

./zen-cli getinfo

ZEN update (when you need to upgrade)

cd ~/source/zen
git pull
cd ~/source/zen/zcutil
./build.sh
./fetch-params.sh

9 thoughts on “Build Zencash (ZEN) wallet on Ubuntu

    • When I check disk usage in the folder for source code and user folder, it’s a little over 3G, and I have the entire block chain already.

      yourusername@YourComputerName:~$ du -hs ~/source/zen/
      2.4G /home/yourusername/source/zen/

      yourusername@YourComputerName:~$ du -hs ~/.zen
      744M /home/yourusername/.zen

  1. I can’t get it running on here. I got it built but when I try there is no zend in the src directory. I may need to try on of the other coins too, but it may just be the ARM processor

  2. I get this when it is compiling.

    g++: error: unrecognized command line option ‘-m64’
    g++: error: unrecognized command line option ‘-m64

Leave a Reply

Your email address will not be published. Required fields are marked *